Add support for docker compose.

pull/21/merge
Kavin 1 month ago
parent 597bdfb23d
commit 099a59cf8a
No known key found for this signature in database
GPG Key ID: 49451E4482CC5BCD
  1. 2
      configure-instance.sh

@ -5,7 +5,7 @@ if [ -z "$(which docker-compose)" ]; then
fi
# Docker-Compose version check, to prevent "Unsupported configuration option"
COMPOSE_VERSION=$(docker-compose version --short)
COMPOSE_VERSION=$(docker-compose version --short 2>/dev/null || docker compose version --short 2>/dev/null)
REQUIRED_COMPOSE_VERSION="1.28.0"
if [[ $(printf '%s\n' "$REQUIRED_COMPOSE_VERSION" "$COMPOSE_VERSION" | sort -V | head -n1) != $REQUIRED_COMPOSE_VERSION ]]; then
echo "Your docker-compose version of $COMPOSE_VERSION is too old. Please upgrade to $REQUIRED_COMPOSE_VERSION or higher."

Loading…
Cancel
Save